Company news / MetaTrader Update Required

MetaTrader Update Required

The FXOpen Team

MetaTrader Update Required

After 1 March 2019, MetaTrader 4 desktop terminal builds below 1118 and MetaTrader 4 Android terminals below 1104 will no longer be supported. Older terminals will not be able to connect to FXOpen trading servers.

We recommend updating your terminals to build 1170 released on December 20, 2018. The update features error fixes and platform stability improvements.

Download MetaTrader 4 Desktop
Download MetaTrader 4 Andriod

Follow the updates on Facebook, Twitter and Telegram.

FXOpen Customer Service
E-mail: [email protected]
Live Chat (24/5)

Latest from Company news

UK Bank Holiday and US Memorial Day Trading Hours Schedule FXOpen Expands Depositing Options Buddha's Birthday Trading Hours Schedule Trading Hours Schedule for the UK Early May Bank Holiday Trading Hours Schedule for the Labour Day

Related articles

UK Bank Holiday and US Memorial Day Trading Hours Schedule
Company news

UK Bank Holiday and US Memorial Day Trading Hours Schedule

Dear Traders,

Due to the UK Bank Holiday and US Memorial Day you will experience the following changes in the trading hours schedule (all times are GMT+3):

Friday, 24th May

Indices CFD:

  • #UK100: trading until 23:00.

Monday, 27th

Company news

FXOpen Expands Depositing Options

FXOpen is pleased to announce a new depositing option, tailored specifically to our clients based in India.

These clients can now easily fund their accounts in Indian Rupees using their online banking service or QR code, providing them with a

Company news

Buddha's Birthday Trading Hours Schedule

Dear Traders,

Due to the Buddha's Birthday Holiday on 15th May, you will experience the following changes in the trading hours schedule (all times are GMT+3):

Tuesday, 14th May

Indices CFD:

  • #HSI: trading until 22:00.

Wednesday, 15th May